Degraded Performance in Coaching section of portal

Incident Report for Forward Thinking Systems

Resolved

We have implemented a fix and are monitoring but so far the issue appears to be resolved.
Posted Sep 22, 2025 - 17:15 EDT

Update

We believe we have isolated the issue and are implementing a fix.
Posted Sep 22, 2025 - 14:30 EDT

Investigating

We are currently investigating slow loading of Drivers and Vehicle event lists in the Coaching portion of Intellihub
Posted Sep 22, 2025 - 13:30 EDT
This incident affected: Portals (IntelliHub).