Slow Device Reporting

Incident Report for Forward Thinking Systems

Resolved

The issue appears to be resolved, any devices still not reporting in will be treated as a new issue.
Posted Aug 31, 2026 - 16:55 EDT

Monitoring

We have implemented a fix and are monitoring to see if the issue is resolved.
Posted Aug 31, 2026 - 15:33 EDT

Identified

We have been investigating slow device reporting in the IntelliHub platform and believe it can be traced back to a back-end GPS database. Currently working with our database provider on a fix.
Posted Aug 31, 2026 - 14:42 EDT

Investigating

We are currently investigating this issue.
Posted Aug 31, 2026 - 09:00 EDT
This incident affected: Portals (IntelliHub).