Cloudflare Outage

Incident Report for Forward Thinking Systems

Resolved

All Systems have been functioning normally since the last update. The issue appears resolved.
Posted Nov 18, 2025 - 13:27 EST

Monitoring

All sites appear restored. We will continue to monitor to ensure all websites are flowing correctly.
Posted Nov 18, 2025 - 09:50 EST

Identified

Cloudflare reports that the cause was found and they are implementing a fix. Sites are still sporadically not loading. We will continue to monitor.
Posted Nov 18, 2025 - 08:15 EST

Investigating

Cloudflare (who handles our DNS and WAF) is experiencing a global outage this morning, affecting the loading of Intellihub and Engage. GPS device traffic is unaffected. We are still investigating the full extent of the outage and will add more info here as it becomes available.
Posted Nov 18, 2025 - 07:36 EST
This incident affected: Portals (IntelliHub, Engage360).