Slow reporting for devices

Incident Report for Forward Thinking Systems

Resolved

The issue appeared to be limited to a specific cell data provider affecting a small subset of customers. We have gotten confirmation that the degraded performance is fixed.
Posted Sep 03, 2026 - 17:30 EDT

Investigating

We are currently investigating slow reporting for Fleetcam and Suntech devices.
Posted Sep 03, 2026 - 16:15 EDT
This incident affected: Portals (IntelliHub).